Granular Insights: Fields are not loading in Field Plans

Incident Report for Granular Support

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 12:32 CST

Identified

We are currently experiencing an issue where fields are not populating in Field Plans. The team has identified the issue and is actively working on a resolution.

----------------------------
To check the status of all issues, please visit:https://granularinsights.statuspage.io/
Posted Dec 05, 2025 - 10:59 CST
This incident affected: Granular Insights (Activities).