The issue causing historical and new imagery to appear as unavailable has been resolved. Please review the affected operation to confirm everything is displaying correctly. If you continue to experience any issues, please reach out to Support. Thanks.
Posted Aug 29, 2025 - 08:35 CDT
Update
The imagery service is currently being restored. New imagery should now be populating as expected; however, some historical datasets remain unavailable. Our team is actively working to recover and backfill the missing historical data.
Posted Aug 28, 2025 - 10:56 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 08:14 CDT
Identified
Defect ID: ORN-8734 Service(s) Impacted: Imagery
We are currently experiencing an issue with imagery not updating. Our imagery team is aware of the problem and is actively working on a solution. They are also working to backfill the missing imagery. We will provide an update once the issue has been resolved.