Next Generation Insights - Accounts – Agency Role switch not updating in NRE

Incident Report for Granular Support

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 08:53 CDT

Identified

Defect ID: CAT-5932
Service(s) Impacted: Accounts

Incident Summary: Accounts – Agency Role switch not updating in NRE

We are currently aware of an issue in NRE where users with access to multiple agencies are unable to switch their context role from one territory to another. At this time, the role remains stuck on the previous selection after attempting to switch.

Our Accounts team is aware of the problem and is working on a fix. We will provide an update as soon as we have more information.

Thank you for your patience.
----------------------------
To check the status of all issues, please visit:https://granularinsights.statuspage.io/
Posted Aug 18, 2025 - 08:57 CDT
This incident affected: Granular Insights (Accounts and Operation Settings).