Granular Insights Status Page URL Change - https://granularinsights.statuspage.io/
Incident Report for Granular Support
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 15:32 CDT
Update
Posted Aug 29, 2023 - 15:27 CDT
Investigating
The Granular Insights status page has a new updated URL.

To view system status or update your current subscription preferences for email and/or text, visit https://granularinsights.statuspage.io/

Thanks,
The Granular Support Team
Posted Aug 29, 2023 - 15:26 CDT