Unable to save newly created notes on Web

Incident Report for Granular Support

Resolved

This incident has been resolved, if you experience this issue going forward please reach out to support at digitalagsupport@corteva.com.
Posted Jun 18, 2025 - 10:31 CDT

Monitoring

A fix has been implemented and we are monitoring, if you continue to experience the inability to save notes on web on Granular Insights please contact support at digitalagsupport@corteva.com.
Posted Jun 17, 2025 - 08:57 CDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 11:31 CDT

Investigating

We are currently experiencing an issue that is not allowing notes to be saved in Granular Insights web. Our team is aware of the issue and is investigating to implement a fix. The mobile app is working as expected, and notes are saving, so use of the Granular Insights Mobile App for notes is able to be utilized. If you have any questions or would like further information on this issue please contact support for assistance at digitalagsupport@corteva.com
Posted Jun 16, 2025 - 11:30 CDT
This incident affected: Granular Insights (Map).